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1: Introduction
This document assumes you have converted a 900-RJ serial keypad into a MIDI
Patch Changer keypad using the MTG conversion kit.

The MIDI Patch Changer is the perfect solution when you need to control MIDI
presets for one or more devices, but a giant keyboard controller or a MIDI
footswitch/pedalboard just won’t do.
The MIDI Patch Changer has all the features you'd expect in a full-featured
patch-changing controller.
o Manual Operation. Manual Mode is used to key-in or scroll-through
Program Change messages with or without MIDI Bank Select messages.
o Preset Operation. Preset mode is for live or studio performance
situations. The unit can send a complete set of 16 patch and bank select
changes for every Preset.
o Expandable and upgradeable. The MIDI Patch Changer is
programmable including re-flashing the firmware.
o Durable. Made with high-quality switches (50 million+ operations) on a
metal sub-frame.

The standard unit includes:
o
o
o
o
o
o

MTG

20-key keypad with 16-character backlit liquid crystal display (LCD).
Power adapter (110-240v AC input to 5v DC output).
Rear-panel RJ connector supports multiple cable types.
RJ-to-USB cable for USB-MIDI connection (using OS built-in driver).
RJ (Cat-5) cable for 5-pin DIN MIDI In and Out (on small external box).
System Exclusive implementation for reading/storing the Presets.
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Understanding the Keypad
The Mode Keys:

The MIDI Patch Changer has three
major function groups (modes).
o Manual Mode is for sending patch
changes by hand “on-the-fly”.
o Preset Mode is for sending prearranged patch changes and MIDI
data during live performance.
o Finally there is a Utility Menu for
changing the keypad preferences.
The three MODE keys indicated by the
arrows (see diagram left) are used to
change the operating mode of the
keypad.

The Numeric Key Section:
The numeric key section is used for manually entering Patch
Change and Bank Select numbers (in decimal). In each
case the number range can be 0 to 127 or 1 to 128 to match
the receiving MIDI device. Future updates may allow for
alphabetic patch numbers (some vintage synths collect
patch sets of 8 or 16 into “banks” called A, B, C, D, etc.).

The Arrow Keys:
The up and down keys are active in all three operating modes. They are
used to manually scroll through banks and patches in Manual Mode, to
manually scroll through presets in Preset Mode, and to navigate the Utility
Menus.

MTG

-5-

MPC Keypad

The Other Keys
The MIDI Channel key is used to change the transmit
channel for patches in Manual Mode as well as to view the
settings for each MIDI channel in a Preset.
The Bank MSB and Bank LSB are used to select/enable/disable the sending of
Banks Select messages in Manual Mode. In this mode they act like a mute
button.

Hooking Up
There are several ways to connect the MIDI Patch Changer to your gear and/or
PC.
5-Pin DIN MIDI Gear

RJ Cable

5v DC

Keypad
MIDI IN

MIDI OUT

OPTIONAL

If you need to connect to 5-pin DIN MIDI gear, then use the
supplied Cat5 cable and supplied MIDI adapter box.
o Plug the short Cat5 cable into the back of the keypad
and into the RS232 MIDI adapter box.
o Plug the supplied DC power adapter into the wall socket and
then into MIDI adapter box.
o Then hook your MIDI gear into the IN and OUT jacks on the
MIDI adapter box.
MTG
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USB to PC (Sequencer, Soft Synth, etc.)

USB Cable

If you are hooking the MIDI Patch Changer keypad to a
PC that has USB, then you can use the supplied RJto-USB cable:
.
o Connect the RJ end into the back of the keypad
o Then connect the USB connector into your PC or USB hub
The PC (Mac or Windows) will use the basic class drivers supplied with the OS.
No additional driver is needed.

Alternate USB to PC (Firmware Upgrade, etc.)

RJ Cable

Keypad

MTG

5v DC

MIDI IN

PC MIDI INTERFACE
(Not Supplied)

MIDI OUT
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2: Manual Mode
In Manual Mode you can send one, two or all three of the following standard MIDI
messages on the MIDI channel of your choosing:
Program Change (always transmitted)

Bank Select MSB - Controller number 0 (optionally transmitted)
Bank Select LSB - Controller number 32 (optionally transmitted)

The LCD will show what the current patch value is and what components are
enabled or disabled. If one or both of the Bank Selects is disabled (muted), then
the LCD will show “···“ next to the name on the LCD. For instance, on the

LCD shown below, the Bank MSB is not enabled, the Bank LSB value is
25 and the Program Change value is 341.

MIDI Channel
Once you have your cables hooked up, the first
thing you should do is set the MIDI channel used
for manual mode. This is done by pressing the
MIDI CH key and using the Up or Down arrow
keys to scroll to the channel you want (1 to 16).
Alternatively you can erase the displayed value
using the CLEAR key and then type in the
1

There is a Utility Menu item for setting the number range to either 0-127 or 1-128 for both
Program Change and Bank Select but it is recommended at this time to stay with the defaults.

MTG
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channel you want and then press ENTER.
Press ENTER to save your new MIDI channel number. You can abandon your
changes by pressing MIDI CH a second time. The MIDI Channel value will be
retained even if power is lost.

Enable/Disable Banks Select(s)
The Bank Select MSB and Bank Select LSB can be enabled and disabled by
repeated depressing of their respective keys.

When the Bank Select is disabled (muted), the three dots appear: “···“. When the
value is being editing the cursor is flashing over the value being edited. When the
value is solid then the value is enabled for transmitting. Normally, when not
editing a bank value, the cursor is flashing over the program change value at the
far right of the LCD since this is the value you will be changing most often.

To Change a Bank Value Without Sending
This allows you to establish what patch you want to send, but not send it yet.
Press one of the Bank Select keys until you are in the edit mode (cursor flashing
on the bank value). Enter the new value for the Bank Select using the number
keys. Press the same Bank Select key again (do NOT press Enter). This
changes the value on the display but does not transmit anything.

To Change a Bank Value With Sending
To Edit a Bank Select and send it immediately (along with the current Patch
value), press one of the Bank Select keys until you are in the edit mode (cursor
flashing on the bank value). Enter the new value for the Bank Select using the
number keys. Press Enter.

MTG
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To Send the Bank and Patch Values
While in Manual Mode, pressing Enter at any time causes all of the displayed
(enabled) data to be transmitted.

Scrolling through Patches
With the cursor flashing on the Patch value, pressing an Up or Down arrow key
causes the displayed patch value to be incremented or decremented by one, and
the new displayed (enabled) data to be transmitted.
If the Patch value overflows or underflows, then the Bank Value (if enabled), is
modified by one also. This allows you to scroll seamlessly over bank boundaries
in both the forward or reverse direction.

Using the Arrow Key on a Bank Select
To quickly change to the next or previous bank, put one of the Bank Select value
in edit mode and press the desired Up or Down arrow key. This will cause the
Bank Select value to change by one, followed by transmission of enabled data.

MTG
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3: Preset Mode
Preset mode allows you to pre-configure the keypad for performance situations
where you need to change patches on a lot of gear with minimum fuss. In this
mode you can set up to 16 patch/bank changes per preset (one per MIDI
channel). Of course you will need to set these values up ahead of time. This is
normally accomplished by using the Librarian Software or by manually sending
System Exclusive dumps (see Appendix A for a description of the System
Exclusive implementation).
There are 100 presets (01-100) and you can move through them using the
number pad or with the arrow keys2.

The number on the left indicates the preset number. The user name for the patch
is shown on the right. It consists of (up to) thirteen ASCII characters.
Each time a new preset is selected the keypad can transmit any or all of the
following information:
Blank Preset Sheet
Bank Select
Bank Select
MSB
LSB

MIDI
Channel
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Arbitrary MIDI Data (pre or post):

Program
Change

2

As of v0.76 Preset Browse mode allows for scrolling through the presets with the arrow keys without
transmitting. Use Enter to transmit the preset you browsed to.

MTG

- 11 -

MPC Keypad

Each component (blank square above) can contain a value (0-127 or 1-128) or it
may be disabled. Disabled values actually contain the number 255. See the
System Exclusive implementation in Appendix A for more information.

Changing Presets By Number
When you begin to type in a number on the 0 through 9 number pad, the display
briefly changes to show only the number being entered in.

When you have completed typing in the Preset number you want, press the
ENTER key. The complete Preset will be transmitted and the display will return
to the standard screen. While entering the number, you can also edit the value
using the CLEAR key.

The MIDI Channel Key
In this mode, the MIDI Channel key is used to browse through the table values
shown on the previous page. Select a preset using the number pad or the arrow
keys. Press MIDI CH. The display will show, for each MIDI channel, what
elements are being transmitted. Again, values that are disabled are shown with
three dots: “···“.

The LCD elements shown from left to right are:
o
o
o
o
o

The C indicates that you are browsing the data for each MIDI channel.
MIDI channel (1 to 16).
Bank Select MSB (user settable).
Bank Select LSB (user settable).
Program Change (user settable).

You can then use MIDI CH to scroll through the MIDI channels and see what you
have previously programmed into the device. Any other key exits this browse
mode (acts as an Escape key).

MTG
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Arbitrary MIDI Data
Each Preset can also send up to 16 bytes of arbitrary MIDI data before or after
the patch change data. This data cannot be edited on the device at this time.
Use the Librarian Software (PC Editor) to configure this data.

MTG
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4: Editing Presets (on the keypad)
You can edit the individual Presets on the device or by sending new values using
System Exclusive. To edit a preset on the device, while in Preset Mode, press
PRE MODE (again). You will asked to verify that you want to edit the current
preset:

Press ENTER to confirm or CLEAR to go back to the previous Preset. In Edit
Preset mode the LCD screen information starts with the letter E.

You can cycle through the various edit screens using the PRE MODE key.
Sub-menu

Navigation
PRE Mode Key

Edit Patch Change Data
Edit Name
View Arbitrary MIDI Data
Save Preset Confirm

Modifying the Preset 3
In Preset Edit mode, the editing is similar to the Manual Mode.
MIDI CH lets you scroll through the list of 16 MIDI channels and on each one you
can assign a Bank Select MSB and/or a Bank Select LSB and/or a Patch Change
value.
Bank MSB moves the cursor to the Bank Select MSB if the cursor is not there
already. If it is, then it enables/disables it. If the Bank Select MSB is enabled and
the cursor is flashing on it’s position, then you can modify the value using either
the arrow keys or typing a new value on the keypad.
Bank LSB moves the cursor to the Bank Select LSB if the cursor is not there
already. If it is, then it enables/disables it. If the Bank Select LSB is enabled and

3

There is no method currently to modify the arbitrary MIDI data field on the keypad.
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the cursor is flashing on it’s position, then you can modify the value using either
the arrow keys or typing a new value on the keypad.
MAN MODE takes on the role of PATCH CHANGE. It moves the cursor to the
Patch Change value if the cursor is not there already. If it is, then MAN MODE
enables/disables it. If the Patch Change is enabled and the cursor is flashing on
it’s position, then you can modify the value using either the arrow keys or typing a
new value on the keypad.

Editing the Name
Press PRE MODE again and you will be prompted for the name you wish to
assign to the Preset. The LCD screen shows N?: to indicate that it is in name
editing mode.
Use the UP and DOWN arrow keys to change each character value (see table).
ENTER moves the cursor to the right and CLEAR moves it to the left.

LCD character table

MTG
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Arbitrary MIDI Data
Press PRE MODE one more time to take you to the screen that shows the first 6
bytes of Arbitrary MIDI Data (if used). The LCD shows Pre: if the data is to be
transmitted before the patch change. The LCD shows Pst: if the data is to be
transmitted after the patch change data.

Saving
To save the Preset, press PRE MODE one more time and you will be prompted
to save the changes. Here you can also edit the Preset number. This allows you
to save the Preset to the same location or you can copy the Preset to a new
location. Once you set the number of the Preset location you want to save to,
Press ENTER to confirm the save. Alternatively, pressing PRE again takes you
back to editing without saving.

Back to Editing
From the Save Preset? prompt, Pressing PRE MODE again takes you back to
the editing screen. See the menu structure table on the next page.
If you want to abandon the changes, press the UTIL button.

MTG
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5: Utility Menu
The menu structure for the MIDI Patch Changer keypad looks like this:
Operating Mode

Sub-menu

Navigation

Manual Mode
PRE

Preset Mode Edit Patch Change Data
Edit Name
View Arbitrary MIDI Data
Save Preset Confirm
UP/DN

Utility Menu Preset Mode (norm/browse)
Receive Program Change
Send a Preset (via Sys Ex)
Patch Range
Bank Select Range
Sys Ex Manufacturer ID
MIDI Monitor
Restore Factory Defaults
Show Version Info
Download New Firmware
To view the Utility Menu, press the UTIL key, then navigate the menu using the
Up and Down arrow keys. The vertical line at the far right of the LCD is meant to
mimic a window scroll bar on a PC. As you move up and down the menu the
scroll bar indicates your relative position in the menu tree.
Press ENTER on the item you wish to view/modify. From within a menu item you
can press CLEAR to abandon a change and return to the menu list.

Preset Mode (v0.76+)
With Preset Mode set to NORMAL, using the arrows keys (or ENTER or typing a
preset number in) causes a Preset data transmit. With Preset Mode set to
BROWSE, the arrow keys do NOT cause a data transmit. Therefore in browse
mode you can scroll through your list of presets until you find the one you like,
then send it using the ENTER key.

MTG
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Receive Program Changes (v0.77+)
The unit can be set to accept program change commands on its MIDI IN. This
allows an external device to send a patch change command to the MIDI Patch
Changer, thus triggering a specific Preset. Beware of MIDI loops if you use this!
This parameter can be turned OFF or set to a single MIDI channel (1 to 16) on
which to receive the program change commands.

Send a Preset (via System Exclusive)
You can send one Preset manually to a host PC using this menu. Type in the
number of the Preset you wish to transmit (1 to 100) and press ENTER. The
keypad will send 153 bytes of Sys Ex data (as described in the appendix).
Make sure your PC is set to NOT echo the data back out again to the Keypad!

In order to send a Preset to the keypad, simply send it at any time from your PC.
The keypad is always ready to receive Sys Ex. It does not have to be configured
to receive Sys Ex (make sure you are using the correct device ID).

Set Patch Range
You can set the range for the Patch Change values to be 1-128 or 0-127.
Underneath, the firmware always transmits the hex values according to the MIDI
Spec. (0x00 to 0x7F), but most MIDI gear uses 1 to 128 for patches.

You can modify the value using the Up and Down arrow keys or the 0 and 1
keys. Press Enter once you have made your selection.
NOTE: The editor/librarian only supports program change numbers 1 to 128.

MTG
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Set Bank Select Range
You can set the range for the Bank Select MSB and LSB values to be 1-128 or 0127. Underneath, the firmware always transmits the hex values according to the
MIDI Spec (0x00 to 0x7F), but most MIDI gear uses 0 to 127 for bank selects.

You can modify the value using the Up and Down arrow keys or the 0 and 1
keys. Press Enter once you have made your selection.
NOTE: The editor/librarian only supports bank select numbers 0 to 127.

System Exclusive Mfg ID
The System Exclusive Manufacturing ID is used to uniquely identify a specific
MIDI device while doing Sys Ex dumps from a host PC. You can adjust the Sys
Ex ID of the MIDI Patch Changer keypad so that it does not conflict with any of
your other MIDI gear.

The displayed value is in hexadecimal (since that is the most common format for
these IDs). You modify the value using the Up and Down arrow keys. Press
Enter once you have made your selection. Remember to use the value you set
when doing System Exclusive communications with the keypad.
NOTE: The editor/librarian does not yet support alternate Mfg IDs.

MIDI Monitor
You can set the MIDI Monitor ON or OFF. This is a very simple one-line display
showing the last MIDI command received. When enabled, the monitor data is
overlaid live on the MIDI Patch Changer LCD regardless of mode or menu. Press
any keypad key to temporarily regain control of the LCD. This setting is not
retained in non-volatile memory.

MTG
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Restore Factory Defaults
This utility function allows you to restore the whole MIDI Patch Changer keypad
to the default factory settings.
NOTE: After the erase/rebuild operation the keypad will automatically reboot, so
if you are connected via USB MIDI, any applications talking to the MIDI keypad
will be “orphaned”. This is the nature of USB. Therefore it is recommended that
you close any open MIDI applications BEFORE you perform the reset (otherwise
you may need to restart any application that is talking to the keypad).

Show Version (v0.77+)
Displays the firmware version number (the “OS” version number) of the keypad.

Download New Firmware
The MIDI Patch Changer will accept .SYX firmware upgrades over 5-pin DIN
MIDI (not USB) from a PC. Download the latest firmware executable from the
website and follow the instructions included with it or Appendix B.

MTG
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6: Using the Windows Editor
Please Note: If anyone wants to craft a new/better editor, please refer to the
system exclusive implementation in the appendix.

You can edit the individual Presets on the device or by sending new values from
a PC using the free editor/librarian (or manually using hand-crafted System
Exclusive data).
The new Preset data can be sent directly from the editor application or
transported via MIDIOX (or similar) if you prefer.
To edit a preset on a Windows PC, install the free MIDIPatchChanger.exe
librarian utility.
If you choose to use MIDIOX to transport the “Sys Ex” files, download it at
http://www.midiox.com .

Installation
MIDIPatchChanger.exe is a standalone program. There are two ways to install
and use it. The first (recommended) way is to use the installation program. This
will install the application in
C:\Program Files\MidiPatcher

Alternatively you can download and unzip just the exe file and place it where you
like, for instance in the main MIDIOX directory.

MTG
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Editor Features

For each Preset, 1 to 100, you can setup the Bank Select and Program Change
data for any or all of the 16 MIDI channels. In addition you can name each
Preset (13 characters maximum) and setup the arbitrary MIDI data for the Preset.
Each time you click on Preset Number up or down, you will be viewing/editing
one of the 100 Presets.

MTG
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NOTE: At this time the editor only supports the default Mfg ID. In addition, the
editor supports Bank Select numbering 0-127 and Program Change numbering
1-128 only. The keypad itself supports flexible numbering so you can account for
the difference manually if you wish (for instance by editing the .Syx files by
hand).
By default all of the Bank Select and Program Change values are disabled. Click
on the checkbox next to the item you wish to enable/disable.

Edit MIDI Data
Click on the Edit button in the Arbitrary MIDI Data box at the bottom of the
screen. This will open up the MIDI Data editor.

The keypad allows you to send any MIDI data either before or after the MIDI
Patch Change and Bank Selects. This might consist of controller changes or Sys
Ex commands.

MTG
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The top box, marked Standard, allows you to insert data using one of the
predefined types.
The center box, marked Custom, lets you enter any data of your choosing. The
value 255 (0xFF) is reserved and cannot be used.

File Operations
All of the files used by the editor/librarian are .SYX System Exclusive files. A file
may be a single Preset file, a 100 Preset file or a firmware upgrade. You should
use descriptive names to differentiate between the file types or it will be
confusing later on when you work with your files.
The Presets can be stored individually or as a bulk set of 100 in .Syx (raw
System Exclusive) file format. These files can be loaded into any software that
operates directly on such files (e.g. MIDIOX). Single Preset .Syx files contain the
target preset # (see Appendix A for more information) and are formatted as a Set
One Preset command. Thus any sequencer or software or device that can load
this data can be used for programming a Preset into the keypad.

From the File menu you can perform the following actions:
o MIDI – Allows you to choose which MIDI connection/method is used to talk
to the keypad.
o New – Erases all the current data and starts with the default settings
(same as exiting the program and restarting it again).
o Open – Read 1 or 100 Presets from a .Syx file into the program.
o Save – Saves 1 or 100 Presets into a .Syx file.
o Download – Downloads 1 or 100 Presets either directly to the keypad or
via the external MIDI transport application.
o Help – Access to the PDF manual and various web resources.
o Exit – Closes the application.

MIDI
There are several ways to manage and send
the data to the keypad. These methods differ
more in the way the file is managed rather than
how the cabling is hooked up.
MTG
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1. None. In this case you don’t update the keypad. You only work with files.
Later on you can download your files to the keypad.
2. Direct. Directly from within the editor/librarian to the keypad. In this case
the keypad is either connected using its USB cable or it is connected
through your existing MIDI interface (5 pin DIN MIDI). This is the most
common setting. You will need to choose your USB connection from the
list of available interfaces.
3. External. In this case files created by the editor/librarian are passed to an
intermediate 3rd party application (such as MIDIOX) for transport. You
would choose this method if you prefer to work at a low level with your
MIDI data.

MIDI Port Selection
Click on “Direct MIDI…” and choose the
MIDI interface you want to work with.
If the keypad is connected you will see its
version information displayed on the
status bar at the bottom of the program.

External Application Selection
If you prefer that your MIDI files are transported to the keypad using a 3rd party
application, choose “External File Application”. The editor/librarian will then open
the default application the OS has configured for the .SYX file type. Your 3rd
party application will then need to choose which MIDI interface to use.

Notes for MIDIOX
If you are using MIDIOX, you should set up MIDIOX’s SysEx configuration. The
following recommended settings can be entered by clicking:
View -> SysEx…

MTG
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Once MIDIOX is configured and you have a Preset edited to your liking, you can
download it to the keypad by following these steps:
o Click on Download. Then choose whether you want to send one or all.
o If you choose one, then you must choose which Preset slot you wish to
save it to (this value is embedded into the .SYX file) and then click on
Continue. The data will be written to an intermediate .SYX file.

MTG
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o Enter a name for the Preset. You may wish to use the same name as the
keypad shows on it’s LCD. Then click on Save.

o The preset file will be saved to disk and then opened in the MIDIOX Sys
Ex window.

o At this point you simply click on Command Window -> Send/Receive
SysEx.

MTG
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o After a moment you should receive a 7-byte ACKnowledge packet (F0 7D
22 24 00 41 F7 or similar). Click on Done. Downloading occurs in the
background on the keypad so even though the keypad has been
programmed, the LCD display is not automatically updated until you do
something on the keypad that requires the LCD to be refreshed (E.g.
change modes or presets).
Close the SysEx window in MIDIOX and when prompted to save the received
data, click on No.

Uploading
This is not a function you would normally need to perform. Uploading is most
easily accomplished using the keypad UTIL MENU key. Close and Open a fresh
MIDIOX SysEx window and then click on
SysEx -> Receive Manual Dump…

MTG

- 28 -

MPC Keypad

MIDIOX then waits for the data from the keypad.
Next, on the keypad, from the UTIL menu, choose
the keypad menu item Send a Preset and enter a
number (1 to 100):

When you press ENTER on the keypad the data will be sent to MIDIOX.

Click Done and then save the data by clicking on
Display Window -> Save As…
Choose a suitable file name (using the default extension of .SYX). By default the
file will be saved in the Syx subdirectory of MIDIOX. You can load that file into
MIDIPatchChanger.exe if you wish to edit it.

MTG
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Firmware Upgrade
New operating system code is made available on the website. This
code can be used to “reflash” the firmware in the keypad. These
files can be sent to the keypad using the editor/librarian or MIDIOX
(or similar). Either way, the keypad must be connected to the PC
using its 5-pin DIN interface box (not via USB).
To perform the upgrade from within the editor/librarian, simply choose your
(Direct) MIDI connection, click the Upgrade button, set the keypad to upgrade
mode (see below) and select the file to download.

There are two ways to set the keypad in a mode that accepts new firmware.
1. The first method is using the UTIL menu. Press the UTIL button and then
press the down arrow key repeatedly until you see the menu item:

Press ENTER and when prompted to confirm (ENTER to upgrade), then press
ENTER again. At this point the MIDI Patch Changer passes control to the
internal MIDI Loader.
MidiLoader v1.00
2. The other method can be used even in the unlikely event that you “brick” the
firmware (cause the device to malfunction due to improper reprogramming).
In this case unplug the keypad. Press and hold down CLEAR and ENTER.
With these two keys down, plug in the powered 5-pin DIN cable/box. Once
power has been applied through the box to the keypad, release the keys. You
should see:
MidiLoader v1.00

To perform the upgrade using MIDIOX, see Appendix C.
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Appendix A: System Exclusive Implementation
Command Types
The table below shows the system exclusive commands supported by the MIDI
Patch Changer. The keypad also responds to a Universal Device Inquiry system
exclusive command.
Command (hex)
04
05
21
22
23
24

Description
Restart
Get Port
Get Global Parameter
Set Global Parameter
Get One Preset
Set One Preset

Size (# bytes)
5
5
8
8
153
7 to 153

General Format
(hex)

F0
<id>
22
<cmd>
<addr>
(data)
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type byte from table above.
Parameter # (0x08 to 0x0E) or Preset # (0x00 to
0x63).
Data (if any). The data format is described below.
End of System Exclusive

Default Responses
Some commands or queries to the MIDI Patch Changer keypad return standard
“yes” (ACKnowledge) or “no” (Not ACKnowledge) responses. Here is the
general form of those responses.
ACK:
(hex)

F0
<id>
22
<cmd>
<addr>
41
F7

MTG

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Echo of whatever the command was.
Echo of whatever the parameter or preset # was.
ACK – ACKnowledge
(parameter or value accepted)
End of System Exclusive
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NACK:
(hex)

F0
<id>
22
<cmd>
<addr>
4E
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Echo of whatever the command was.
Echo of whatever the parameter or preset # was.
NACK – Not ACKnowledge
(parameter or value was out of range, or error)
End of System Exclusive

Restart Command
You can command the keypad to reboot by issuing this command. If you are
connected using USB, then you may need to close and reopen the ports in your
MIDI software.
Transmitted:
(hex)

F0
7D
22
04
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
End of System Exclusive

Received: ACK packet (then the keypad reboots)

Get Port Command
You can query the keypad to determine if the keypad is connected using it’s 5-pin
DIN cable/box or it’s USB cable using this command.
Transmitted:
(hex)

Received:
(hex)

F0
7D
22
05
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
End of System Exclusive

F0
7D
4D or 55

System Exclusive
Manufacturer ID. User settable – default is 7D.
4D = ‘M’ = MIDI
55 = ‘U’ = USB
Command type.
End of System Exclusive

05
F7
MTG
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Get/Set Global Parameter List
The following table describes the address and data elements that are valid for
the Get/Set Global Parameter commands.
Parameter #
(hex)
08

Value
(binary)
0000 nnnn

09

0000 000x

0A

0000 000x

0C

0ddd dddd

0E

0000 000m

Description
n = MIDI Channel for manual mode
0 to 15
x = Program Change number range
0 is 0-127
1 is 1-128
x = Bank Select number range
0 is 0-127
1 is 1-128
d = Sys Ex Mfg ID (default is 7D)
01 to 7D (7E and 7F are reserved)
m = 0 = Preset Mode NORMAL
m = 1 = Preset Mode BROWSE

Using other parameter numbers is undefined.

Get Global Parameter Command
By sending a Get Global Parameter Sys Ex command from a host device, the
user can query the settings that normally require the use of the Utility menu. In
this implementation one parameter byte is read at a time from the table listed
above. Byte addresses outside of the parameter list range are ignored.
The command reads writes a single byte from the keypad, but the data value is
received as two bytes over MIDI. The first byte is the most significant nibble of
the data. The second byte is the least significant nibble of the data.
Received:
(hex)
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F0
7D
22
21
<addr>
<msn>
<lsn>
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Parameter # from parameter list table.
Most significant nibble of the received value.
Least significant nibble of the received value.
End of System Exclusive
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Example: Read the Manufacturer ID
Transmitted:
(hex)

Received:
(hex)

F0
7D
22
21
0C
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Parameter # from parameter list table.
End of System Exclusive

F0
7D
22
21
0C
07
0D
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Parameter # from parameter list table.
Most significant nibble of the value 7D.
Least significant nibble of the value 7D.
End of System Exclusive

Set Global Parameter Command
By sending a Set Global Parameter Sys Ex command from a host device, the
user can change the settings that normally require the use of the Utility menu. In
this implementation one parameter byte is changed at a time from the parameter
list table. Byte addresses outside of the parameter list range are ignored.
The command writes a single byte into the keypad, but the new data value is
transmitted as two bytes. The first byte is the most significant nibble of the data.
The second byte is the least significant nibble of the data.
(hex)
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F0
7D
22
22
<addr>
<msn>
<lsn>
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Parameter # from parameter list table.
Most significant nibble of the value.
Least significant nibble of the value.
End of System Exclusive
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Example: Set the MIDI Channel for manual mode to channel 2 (value = 0x01).
Transmitted:
(hex)

F0
7D
22
22
08
00
01
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Parameter # from parameter list table.
Most significant nibble of the value 01.
Least significant nibble of the value 01.
End of System Exclusive

Received: ACK packet

Get One Preset Command
By sending a Get Preset Sys Ex command from a host device, the user can
query and save the settings for a single Preset. A Preset consists of the
following data:
o 13 character ASCII name
o 16 MIDI channels worth of Bank MSB/Bank LSB/Patch Change. The
values for these bytes are 0x00 to 0x7F regardless of user preferences.
Disabled (unused) values will be 0x80 or 0xFF. These values are
transmitted as most significant/least significant byte pairs; therefore this
section of the data will be 16 x 3 x 2 = 96 bytes.
o Sixteen bytes of arbitrary MIDI data. This data can contain any MIDI data.
Unused data elements contain 0xFF. Again it is transmitted at msn/lsn
byte pairs; therefore this section of data will be 16 x 2 = 32 bytes.
o Three bytes of configuration data (see blow) 3 x 2 = 6 bytes.
A total received packet then includes all of the above plus the system exclusive
packet header and EOX byte. A total received preset is 153 bytes.
Command:
(hex)
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F0
7D
22
23
<pre>
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Preset # 0x00 to 0x63 (0 to 99 decimal).
End of System Exclusive
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Example: Read the last Preset data

Transmitted:
(hex)

Received:
(hex)

F0
7D
22
23
63
F7

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Get the last preset
End of System Exclusive

F0
7D
22
24
63
<
:
>
<
:
:
:
>
<
:
:
:
>
00
P/P LSN

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type (ready for re-transmission).
Preset number.

00
00
00
00
F7

MTG

13 bytes of ASCII data for the Preset Name

16 sets of (3 bytes x 16 MIDI channels)
Bank Select MSB/Bank Select LSB/Patch Change
bytes sent as msn/lsn byte pairs. 96 bytes total

16 byte pairs of arbitrary MIDI data.

Pre/Post byte most significant nibble (always 0)
Pre/Post byte least sig nibble
(00 = Pre, 01 = Post)
Reserved
Reserved
Reserved
Reserved
End of System Exclusive
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Set One Preset Command
The Set Preset Sys Ex command allows you to write one preset to the MIDI
Patch Changer keypad. This command is variable length in that you don’t need
to send the entire 153 bytes. You can just send what you want and terminate
with an EOX byte. The remainder of the preset you are modifying will be
“disabled” (all values set to 0xFF). Therefore you can set the name and only a
couple of patch change sets if that is all you need.

A Preset consists of the following data:
o 13 character ASCII name. Use space characters to pad if necessary.
o Up to 16 MIDI channels worth of Bank MSB/Bank LSB/Patch Change.
The values for these bytes are 0x00 to 0x7F regardless of user
preferences. Disabled (unused) values should be 0xFF. These values
are transmitted as most significant/least significant byte pairs; therefore
this section of the data will be up to 16 x 3 x 2 = 96 bytes.
o Up to 19 bytes of (optional) arbitrary MIDI data. This data can contain any
MIDI data. Unused data elements should contain 0xFF.
Again it is
transmitted at msn/lsn byte pairs; therefore this section of data will be up
to 19 x 2 = 38 bytes.

Transmitted:
(hex)
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F0
7D
22
24
<pre>
<
:
>
<
:
:
:
>
<
:
:
:
>

System Exclusive
Manufacturer ID. User settable – default is 7D.
Device ID for the MIDI Patch Changer.
Command type.
Preset # 0x00 to 0x63 (0 to 99 decimal).
13 bytes of ASCII data for the Preset Name

Up to 16 sets of (3 bytes x 16 MIDI channels)
Bank Select MSB/Bank Select LSB/Patch Change
bytes sent as msn/lsn byte pairs. 96 bytes max.

16 byte pairs of arbitrary MIDI data
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00
P/P LSN
00
00
00
00
F7

Pre/Post byte most significant nibble (always 0)
Pre/Post byte least sig nibble
(00 = Pre, 01 = Post)
Reserved
Reserved
Reserved
Reserved
End of System Exclusive

Received: ACK packet

Example:

In the data captured above you can see the following elements (in order):
o The green portion represents the Sys Ex header [F0 … 00].
o The blue portion represents the ASCII patch name [41 … 20].
o The white portion represents the MSB/LSB/Pgm Chg data (16 of).
Remember that the bytes are split into MSN/LSN pairs.
o The yellow portion represents the arbitrary MIDI data section. In this case
we have the following MIDI data (again in MSN/LSN pairs):
o 09 01 03 04 07 0F = 91 34 7F (note on)
o 08 01 03 04 07 0F = 81 34 7F (note off for above)
o 09 02 03 04 07 0F = 92 34 7F (note on, different channel)
o 08 02 03 04 07 0F = 82 34 7F (note off for above)
o 00 01 00 02 03 00 04 00 05 00 05 00 06 (sample MIDI gibberish)
o The red F7 is the End-of-Exclusive.
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Universal Device Inquiry
In response to the Universal Device Inquiry command (F0 7E 7F 06 01 F7), the
keypad responds with a 16-character ASCII string indicating the product name
and version. For example, “MIDIPatch v0.79”.

MTG
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Appendix B: Sys Ex Firmware Update via MIDIOX
You can “reflash” the firmware in the MIDI Patch Changer by carefully following
the procedure outlined in this section. Obtain the latest firmware in .SYX format
from the website. Again we show the process using MIDIOX, but you should be
able to use any similar program (and of course the editor/librarian on a Windows
PC).

Configure MIDIOX
The configuration is the same as described in the Download Preset section of
this manual. It is repeated here for convenience. Set the Sys Ex properties of
MIDIOX by clicking:
View -> SysEx…

then

SysEx->Configure .

Use the recommended setting shown in the above Configure panel.
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Prepare the Keypad for Download
You must use the 5-pin DIN cable/box for firmware upgrades. You cannot
upgrade using the provided MiniTerm USB cable. The firmware upgrade will
not affect your stored presets (unless the firmware upgrade is designed to add
new features that make the old preset data invalid).
There are two ways to set the keypad in a mode that accepts new firmware.
3. The first method is using the UTIL menu. Press the UTIL button and then
press the down arrow key repeatedly until you see the menu item:

Press ENTER and when prompted to confirm (ENTER to upgrade), then
press ENTER again. At this point the MIDI Patch Changer passes control to
the internal MIDI Loader.
MidiLoader v1.00
4. The other method can be used even in the unlikely event that you “brick” the
firmware (cause the device to malfunction due to improper reprogramming).
In this case unplug the keypad. Press and hold down CLEAR and ENTER.
With these two keys down, plug in the powered 5-pin DIN cable/box. Once
power has been applied through the box to the keypad, release the keys. You
should see:
MidiLoader v1.00

Test the Communication
If you send a Universal Device Inquiry system exclusive packet to the keypad, it
will respond with the MidiLoader version packet. In MIDIOX, click:
View -> SysEx…
Then from the SysEx menu click
Command Window -> Load File…
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Choose the file Universal Device Inquiry.syx and click open. Click
Command Window -> Send/Receive Sysex
The keypad will respond with 24 bytes. Click on Done. Next click on
Display Window -> Hex View Swap
You may have to enlarge the window a little, but you should see something like
this:

Now you can proceed with the firmware upgrade.

Firmware Upgrade
Close the SysEx View window and open it again to get an empty window. If you
are prompted to save anything, click No.
Open the new firmware file by clicking
Command Window -> Load File…

MTG
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Choose the file required for the upgrade (E.g. MidiPatch_v1_00.syx). You
should see that a fairly large file is opened.

Click on
Command Window -> Send/Receive Sysex
The upgrade takes approximately 30 seconds. Do not touch the computer or
keypad during this time. At the end of the upgrade the keypad will reboot. Also
the MIDIOX screen will show a fairly large number of transactions.

You can close MIDIOX (don’t save anything) and begin using the updated
keypad.
MTG
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